Sondage

Comment fonctionne chez vous le bouton "POST NON LU" ?

Il donne tous les sujets ayant des posts non lus quelle que soit leur date
7 (53.8%)
Il ne donne que les sujets ayant des posts non lus arrivés après ma dernière  connection
4 (30.8%)
Je ne sais pas car je ne l'utilise jamais
1 (7.7%)
Je ne sais pas car je ne garde jamais de posts non lus
0 (0%)
Je ne comprend pas la différence
1 (7.7%)

Total des votants: 11

A A A A Auteur Sujet: Problème sur le bouton "POST NON LU"  (Lu 9479 fois)

Hors ligne AstraTJ

  • Concept Car
  • *
  • Karma: 0
  • Messages: 7606
  • Sexe: Homme
  • Localisation: F-31 Toulouse
  • Pays: France
  • Mon toit + moi + les cieux qui le veulent ...
    • Voir sa galerie
    • Voir sa présentation
Problème sur le bouton "POST NON LU"
« le: 05 août 2007 à 15:29:34 »
Bonjour,

J'ouvre ce sujet à propos du problème du bouton "POST NON LU" déjà signalé par ailleurs, et pour lui associer un sondage.


Ce bouton "POST NON LU" (situé dans le bandeau de boutons à côté du bouton "CALENDRIER") devrait faire apparaître tous les sujets qui ont des posts non lus, quelle que soit la date d'arrivée de ces posts, avant ou après la dernière connexion

Le problème, c'est que (chez moi en tous cas), ce bouton ne fait apparaître que les sujets qui comprennent des posts non lus arrivés après depuis la dernière connexion. :cry:
En fait, chez moi il fait exactement la même chose que le "Sujets non lu depuis votre dernière connexion" (situé tout en haut de la page) :bizarre1:


Ce problème est assez bloquant, vu que du coup, on ne peut pas avoir accès aux posts non lus qui étaient déjà présents lors de la précédente connexion, et qu'on n'a pas pris la peine de lire à ce moment-là. :cry:

(je précise que ces sujets avec posts non lus anciens existent, puisqu'ils sont bien marqués avec le symbole "nouveaux" dans leslistes des Sections)


« Modifié: 05 août 2007 à 15:39:15 par AstraTJ »
Astra Twin Top 1.9 CDTI 150 Cosmo - Pannacotta, Inserts Champagne, Sièges Cuir Brun chauffants :cool2: , filet anti-remous, ....
GPS Mio A701 (MioMap)

Hors ligne GBW067

  • Mobylette
  • *
  • Karma: 0
  • Messages: 378
  • Sexe: Homme
  • Localisation: Gouy-lez-Piéton - Belgique
  • Pays: Belgique
  • Ravi...ravi...ravi...pourvu que cela dure
Re : Problème sur le bouton "POST NON LU"
« Réponse #1 le: 05 août 2007 à 18:06:37 »
Ce ne serait pas un probème de cookies ça ?  :reflexion:
OPEL Astra Break Cosmo 1.7 CDTi 100CH
ODB, CD30 MP3, Clim Auto, Radars de recul, Rétros Rabattables électriques, Régulateur de vitesse

La vie est une maladie mortelle sexuellement transmissible

Hors ligne AstraTJ

  • Concept Car
  • *
  • Karma: 0
  • Messages: 7606
  • Sexe: Homme
  • Localisation: F-31 Toulouse
  • Pays: France
  • Mon toit + moi + les cieux qui le veulent ...
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #2 le: 05 août 2007 à 20:14:30 »
Ce ne serait pas un probème de cookies ça ?  :reflexion:
Je ne sais pas.

Ce que je sais, c'est que "POST NON LU" correspond au lien
https://www.astraforum.fr/index.php?action=unread;all

alors que "Sujets non lu depuis votre dernière connexion" correspond au lien
https://www.astraforum.fr/index.php?action=unread

Donc, apparemment, l'option ";all" est ignorée chez moi ... mais pourquoi ? :reflexion:

... sachant que ça marchait avant, et que c'est depuis l'évolution / migration d'avril que ça ne marche plus :cry:

« Modifié: 05 août 2007 à 20:19:54 par AstraTJ »
Astra Twin Top 1.9 CDTI 150 Cosmo - Pannacotta, Inserts Champagne, Sièges Cuir Brun chauffants :cool2: , filet anti-remous, ....
GPS Mio A701 (MioMap)

Hors ligne Greg

  • V.I.P
  • *
  • Karma: 0
  • Messages: 795
  • Sexe: Homme
  • Localisation: Genève
  • Pays: Suisse
    • Astra Forum
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #3 le: 05 août 2007 à 20:40:57 »
Essaye de vider tes cookies ;)

Chez moi ca fonctionne niquel !

Hors ligne AstraTJ

  • Concept Car
  • *
  • Karma: 0
  • Messages: 7606
  • Sexe: Homme
  • Localisation: F-31 Toulouse
  • Pays: France
  • Mon toit + moi + les cieux qui le veulent ...
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #4 le: 05 août 2007 à 21:19:55 »
Essaye de vider tes cookies ;)

Chez moi ca fonctionne niquel !
J'ai vidé mes cookies (ainsi que mes fichiers temporaires), puis je me suis déconnecté et reconnecté
"POST NON LU" --> les plus anciens messages ont disparu
"Sujets non lu depuis votre dernière connexion"  -> je n'ai pas testé  :combat2:

J'ai re-vidé mes cookies (ainsi que mes fichiers temporaires), puis je me suis déconnecté puis re-vidé mes cookies (et mes fichiers temporaires) et reconnecté
"POST NON LU" --> je n'ai plus rien
"Sujets non lu depuis votre dernière connexion"  -> je n'ai rien (ça, c'est normal)

En fait, il semblerait que les posts affichés (dans les 2 cas) , ce ne sont pas ceux depuis la dernière connexion, mais ceux depuis l'avant-dernière déconnexion
... j'avais déjà remarqué cette ambiguïté auparavant.

Est-ce que cela ne serait pas lié à la shoutbox (je l'ai paramétrée à "présente" et "en bas") ?
Pour info, j'ai toujours dans ces pages un status "Error on page"
Astra Twin Top 1.9 CDTI 150 Cosmo - Pannacotta, Inserts Champagne, Sièges Cuir Brun chauffants :cool2: , filet anti-remous, ....
GPS Mio A701 (MioMap)

Hors ligne 18Pouces

  • V.I.P
  • *
  • MembreHonneur
  • Karma: 0
  • Messages: 25485
  • Sexe: Homme
  • Localisation: Région Parisienne
  • Plus d'Astra...
    • AstraForum
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #5 le: 06 août 2007 à 00:00:33 »
Bon je viens de tester et moi c'est carrément l'inverse :bizarre1:
Le POST NON LU fonctionne très bien mais c'est le "Sujets non lu depuis votre dernière connexion" qui fonctionne comme POST NON LU :bizarre2:

Je vais rester demain matin :wink:
BMW 135i 3.0l 306ch Sport Design | Full Option
____________________
Ex : BMW 130i 3.0l 265ch Hatch Pack M | Full Option
Ex : Audi A2 | 1.4l 75ch | Pack Plus S-line | Noir nacrée | Open Sky (Toit Ouvrant Panoramique)
Ex : Astra H Cosmo 1.7CDTI 100ch@135ch & 327Nm | 18" | Bi Xénon | CID et CD30Mp3 | Pack Visibilité | Pack Assistance | Gris Eclair

Hors ligne AstraTJ

  • Concept Car
  • *
  • Karma: 0
  • Messages: 7606
  • Sexe: Homme
  • Localisation: F-31 Toulouse
  • Pays: France
  • Mon toit + moi + les cieux qui le veulent ...
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #6 le: 06 août 2007 à 00:27:17 »
Bon je viens de tester et moi c'est carrément l'inverse :bizarre1:
Le POST NON LU fonctionne très bien mais c'est le "Sujets non lu depuis votre dernière connexion" qui fonctionne comme POST NON LU :bizarre2:

Je vais rester demain matin :wink:
:o :o :o
Ah ! donc tu as quelque chose qui cloche aussi ... mais si c'est l'inverse, c'est bizarre :bizarre2:
Astra Twin Top 1.9 CDTI 150 Cosmo - Pannacotta, Inserts Champagne, Sièges Cuir Brun chauffants :cool2: , filet anti-remous, ....
GPS Mio A701 (MioMap)

Hors ligne 18Pouces

  • V.I.P
  • *
  • MembreHonneur
  • Karma: 0
  • Messages: 25485
  • Sexe: Homme
  • Localisation: Région Parisienne
  • Plus d'Astra...
    • AstraForum
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #7 le: 06 août 2007 à 07:07:08 »
Désolé, je viens de retester et ça fonctionne très bien :cool4:
BMW 135i 3.0l 306ch Sport Design | Full Option
____________________
Ex : BMW 130i 3.0l 265ch Hatch Pack M | Full Option
Ex : Audi A2 | 1.4l 75ch | Pack Plus S-line | Noir nacrée | Open Sky (Toit Ouvrant Panoramique)
Ex : Astra H Cosmo 1.7CDTI 100ch@135ch & 327Nm | 18" | Bi Xénon | CID et CD30Mp3 | Pack Visibilité | Pack Assistance | Gris Eclair

Hors ligne AstraTJ

  • Concept Car
  • *
  • Karma: 0
  • Messages: 7606
  • Sexe: Homme
  • Localisation: F-31 Toulouse
  • Pays: France
  • Mon toit + moi + les cieux qui le veulent ...
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #8 le: 06 août 2007 à 13:02:33 »
Désolé, je viens de retester et ça fonctionne très bien :cool4:
C'est peut-être une piste intéressante, de savoir pourquoi hier tu as eu des soucis et pas aujourd'hui.

Je me pose une question :
Il y a divers moyens de se connecter (dans la partie haute de toute page, en page d'accueil, ou alors en lançanbt une action qui a besoin d'être connecté, ...)
Est-ce que toutes sont équivalentes ?
Est-ce que les différents comportements observés ne dépendraient pas de la façon dont on se connecte ... ou peut-être aussi dont on se déconnecte ?
Astra Twin Top 1.9 CDTI 150 Cosmo - Pannacotta, Inserts Champagne, Sièges Cuir Brun chauffants :cool2: , filet anti-remous, ....
GPS Mio A701 (MioMap)

Hors ligne AstraTJ

  • Concept Car
  • *
  • Karma: 0
  • Messages: 7606
  • Sexe: Homme
  • Localisation: F-31 Toulouse
  • Pays: France
  • Mon toit + moi + les cieux qui le veulent ...
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #9 le: 06 août 2007 à 13:09:26 »
Comme j'ai dit précédemment, en fait, il semble que "Sujets non lu depuis votre dernière connexion" donne non pas les non lus depuis la dernière connexion, mais les non lus depuis l'avant-dernière connexion ... ce qui en soit n'est pas gènant pour ce lien... mais c'est peut-être ça qui a fait que tu as eu un comportement qui semble différent d'une fois à l'autre.

En tous cas, moi, les 2 liens font rigoureusement la même chose.
Astra Twin Top 1.9 CDTI 150 Cosmo - Pannacotta, Inserts Champagne, Sièges Cuir Brun chauffants :cool2: , filet anti-remous, ....
GPS Mio A701 (MioMap)

Hors ligne 18Pouces

  • V.I.P
  • *
  • MembreHonneur
  • Karma: 0
  • Messages: 25485
  • Sexe: Homme
  • Localisation: Région Parisienne
  • Plus d'Astra...
    • AstraForum
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #10 le: 06 août 2007 à 17:27:33 »
Comme j'ai dit précédemment, en fait, il semble que "Sujets non lu depuis votre dernière connexion" donne non pas les non lus depuis la dernière connexion, mais les non lus depuis l'avant-dernière connexion ... ce qui en soit n'est pas gènant pour ce lien... mais c'est peut-être ça qui a fait que tu as eu un comportement qui semble différent d'une fois à l'autre.

En tous cas, moi, les 2 liens font rigoureusement la même chose.
Euh nan :smiley:
Hier voyant que j'avais le même résultat que POST NON LU, je me suis deconnecté et reconnecté au moins 3/4 fois :cool2: et tjs de la même manière :wink:

Je pense qu'il faut un minimun de temps hors connexion...
BMW 135i 3.0l 306ch Sport Design | Full Option
____________________
Ex : BMW 130i 3.0l 265ch Hatch Pack M | Full Option
Ex : Audi A2 | 1.4l 75ch | Pack Plus S-line | Noir nacrée | Open Sky (Toit Ouvrant Panoramique)
Ex : Astra H Cosmo 1.7CDTI 100ch@135ch & 327Nm | 18" | Bi Xénon | CID et CD30Mp3 | Pack Visibilité | Pack Assistance | Gris Eclair

Hors ligne AstraTJ

  • Concept Car
  • *
  • Karma: 0
  • Messages: 7606
  • Sexe: Homme
  • Localisation: F-31 Toulouse
  • Pays: France
  • Mon toit + moi + les cieux qui le veulent ...
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #11 le: 06 août 2007 à 19:06:43 »
Euh nan :smiley:
Hier voyant que j'avais le même résultat que POST NON LU, je me suis deconnecté et reconnecté au moins 3/4 fois :cool2: et toujours de la même manière :wink:

Je pense qu'il faut un minimun de temps hors connexion...
Oui, très possible que le temps hors connexion ait joué.

Mais ce qui es sûr, c'est qu'avec "Sujets non lu depuis votre dernière connexion", on voit quand même certains posts qui étaient déjà présents lors de la session précédente.

"avant la dernière connexion" ne doit pas se comprendre comme "avant la dernière période où on était connecté" (dernière session), mais plutôt comme "avant la dernière fois où on a fait le login" [ou peut-être même plus vieux].

C'est pas un mal en soi, au contraire, mais je le précise car voir des sujets nouveaux qu'on avait déjà vu lors de la session précédente (sans que de nouveaux posts ne soient arrivés) n'est pas le critère de distinction des deux fonctions, il faut raisonner sur des posts plus anciens.


Bref ...
Vous voyez une piste pour mon problème :?:
Ou bien y a-t-il une recette quelqconque pour arriver à mes fins d'une autre façon ? (autre lien avec éventuellement d'autres options :?:

Merci d'avance,
et désolé pour mes sollicitations :wink:

Astra Twin Top 1.9 CDTI 150 Cosmo - Pannacotta, Inserts Champagne, Sièges Cuir Brun chauffants :cool2: , filet anti-remous, ....
GPS Mio A701 (MioMap)

Hors ligne Greg

  • V.I.P
  • *
  • Karma: 0
  • Messages: 795
  • Sexe: Homme
  • Localisation: Genève
  • Pays: Suisse
    • Astra Forum
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #12 le: 06 août 2007 à 19:23:26 »
On en a pas trop parlé... Mais quel navigateur utilises-tu et dans quel version ?

Hors ligne AstraTJ

  • Concept Car
  • *
  • Karma: 0
  • Messages: 7606
  • Sexe: Homme
  • Localisation: F-31 Toulouse
  • Pays: France
  • Mon toit + moi + les cieux qui le veulent ...
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #13 le: 06 août 2007 à 19:34:12 »
On en a pas trop parlé... Mais quel navigateur utilises-tu et dans quel version ?
IE6

Effectivement, j'aurais du le rappeler.
Astra Twin Top 1.9 CDTI 150 Cosmo - Pannacotta, Inserts Champagne, Sièges Cuir Brun chauffants :cool2: , filet anti-remous, ....
GPS Mio A701 (MioMap)

Hors ligne Greg

  • V.I.P
  • *
  • Karma: 0
  • Messages: 795
  • Sexe: Homme
  • Localisation: Genève
  • Pays: Suisse
    • Astra Forum
    • Voir sa galerie
    • Voir sa présentation
Re : Problème sur le bouton "POST NON LU"
« Réponse #14 le: 06 août 2007 à 21:08:57 »
IE6

Effectivement, j'aurais du le rappeler.


As-tu la possibilitée de passer à IE7 ou d'essayer avec FireFox ?

 


* Qui est en ligne

  • user Invités: 58 user Robots: 3 user Caché: 0 user Membres: 0
  • Flèche Membres en ligne:
    Point Google (3)